LAB 3. eBGP Peering
LAB 3. eBGP Peering
Kita akan belajar konfigurasi e-BGP Peersnya, yaitu antara R2 dan R3. Kali ini kita akan menggunakan ip physical sebagai bgp peersnya. Tambahkan satu router dan konfigurasi IP addressnya dibawah. Intinnya kita akan manyambungkan Internal BGP dan External BGP.
Konfigurasi IP address pada f1/0 di Router 2
R2:
Router-2(config)#int f1/0
Router-2(config-if)#ip add 23.23.23.2 255.255.255.0
Router-2(config-if)#no shutdown
Konfigurasi IP Address pada router 3
R3:
Router-3(config)#int fa0/0
Router-3(config-if)#ip add 23.23.23.3 255.255.255.0
Router-3(config-if)#no sh
Router-3(config-if)#ex
Router-3(config)#int loopback 0
Router-3(config-if)#ip add 3.3.3.3 255.255.255.255
Router-3(config-if)#ex
Konfigurasi BGP.
R2:
Router-2(config)#router bgp 12
Router-2(config-router)#neighbor 23.23.23.3 remote-as 3
R3:
Router-3(config)#router bgp 3
Router-3(config-router)#neighbor 23.23.23.2 remote-as 12
Router-3(config-router)#network 3.3.3.3 mask 255.255.255.255
Cek BGP Peernya.
R3:
Router-3(config)#do show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 3
BGP table version is 4, main routing table version 4
3 network entries using 396 bytes of memory
3 path entries using 156 bytes of memory
4/3 BGP path/bestpath attribute entries using 672 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1280 total bytes of memory
BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
23.23.23.2 4 12 5 4 4 0 0 00:00:53 2
Kita juga liat sudah ada 2 route atau belum?
R3:
Router-3(config)#do show ip bgp
BGP table version is 4, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 3.3.3.3/32 0.0.0.0 0 32768 i
*> 11.11.11.11/32 23.23.23.2 0 12 i
*> 22.22.22.22/32 23.23.23.2 0 0 12 i
Router-3(config)#
Setelah itu coba kita ping ke Router3 ke Router 1.
R3:
Router-3(config)#do ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router-3(config)#
Ternyata belum terhubung, coba kita lihat BGP di Router 1.
R1:
Router-1(config)#do sh ip bgp
BGP table version is 3, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* i3.3.3.3/32 23.23.23.3 0 100 0 3 i
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
Router-1(config)#
Kita bisa melihat bahwa route BGP dari R3 (3.3.3.3) tidak ada tanda > bestnya. Hal tersebut dikarenakan IP Next Hopnya tidak reachable dari R1. Yang menyebabkan ketika paket ping dikirim dan sampai ke R1, R1 tidak mengetahui cara untuk mengembalikan paket icmp tersebut ke R3.
Kita cek routing table di R1.
Router-1(config)#do sh ip route bgp
22.0.0.0/32 is subnetted, 1 subnets
B 22.22.22.22 [200/0] via 2.2.2.2, 00:18:19
Router-1(config)#
Kita bisa melihat bahwa tidak satupun route yang berasal dari R3 baik itu interface loopback maupun physicalnya. Terutama IP 23.23.23.3 yang menjadi next hop menuju ke 3.3.3.3.
Ada beberapa cara yang bisa dilakukan, salah satunya adalah mengadvertise network 23.23.23.0 ke BGP pada R2.
R2:
Router-2(config)#router bgp 12
Router-2(config-router)#network 23.23.23.0 mask 255.255.255.0
Cek lagi di sisi R1.
R1:
Router-1(config)#do sh ip bgp
BGP table version is 5, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i3.3.3.3/32 23.23.23.3 0 100 0 3 i
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i23.23.23.0/24 2.2.2.2 0 100 0 i
Router-1(config)#
Kita bisa melihat telah muncul route 23.23.23.0 serta pada route 3.3.3.3 sudah muncul tanda > best yang dikarenakan next hopnya sudah reachable.
Kita coba lakukan tes ping kembali dari R3.
R3:
Router-3#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/60 ms
Router-3#
Akhirnya berhasil reply. Sekarang kita melakukan ping dari R1.
R1:
Router-1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router-1#
Ternyata hasilnya time out… sekarang gunakan source yang ipnya sudah diketahui R3. Cek dulu IPnya R1 yang dikenali oleh R3 apa saja.
R3:
Router-3#show ip route 3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0 11.0.0.0/32 is subnetted, 1 subnets
B 11.11.11.11 [20/0] via 23.23.23.2, 00:10:51 22.0.0.0/32 is subnetted, 1 subnets
B 22.22.22.22 [20/0] via 23.23.23.2, 00:10:51 23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, FastEthernet0/0
L 23.23.23.3/32 is directly connected, FastEthernet0/0
Ternyata hanya ip 11.11.11.11 saja, maka gunakan sebagai sourcenya.
R1:
Router-1#ping 3.3.3.3 source 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 11.11.11.11
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/26/44 ms
Router-1#
Kita lakukan ping dengan menambahkan ping source. Cara yang sama bisa dilakukan yaitu mengadvertise network 12.12.12.0 ke BGP pada R1.
R1:
Router-1(config)#router bgp 12
Router-1(config-router)#network 12.12.12.0 mask 255.255.255.0
Cek di R3 terlebih dahulu, pastikan network 12.12.12.0 sudah dikenali.
R3:
Router-3#show ip route bgp
22.0.0.0/32 is subnetted, 1 subnets
B 22.22.22.22 [20/0] via 23.23.23.2, 00:50:59
11.0.0.0/32 is subnetted, 1 subnets
B 11.11.11.11 [20/0] via 23.23.23.2, 00:50:59
12.0.0.0/24 is subnetted, 1 subnets
B 12.12.12.0 [20/0] via 23.23.23.2, 00:01:20
Router-3#
Lakukan tes ping kembali dari R1 tanpa menggunakan source.
R1:
Router-1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/48 ms
Router-1#
Hasilnya langsung Reply atau terhubung.
Komentar
Posting Komentar